This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate rustdesk

Dependencies

(24 total, 2 outdated)

CrateRequiredLatestStatus
 whoami^1.21.2.1up to date
 serde_derive^1.01.0.143up to date
 serde^1.01.0.143up to date
 serde_json^1.01.0.83up to date
 cfg-if^1.01.0.0up to date
 lazy_static^1.41.4.0up to date
 sha2^0.100.10.2up to date
 repng^0.20.2.2up to date
 libc^0.20.2.131up to date
 flexi_logger^0.220.23.0out of date
 runas^0.20.2.1up to date
 dasp^0.110.11.0up to date
 rubato^0.120.12.0up to date
 samplerate^0.20.2.4up to date
 async-trait^0.10.1.57up to date
 uuid^1.01.1.2up to date
 clap^3.03.2.17up to date
 rpassword^7.07.0.0up to date
 base64^0.130.13.0up to date
 sysinfo^0.240.25.2out of date
 num_cpus^1.131.13.1up to date
 bytes^1.21.2.1up to date
 default-net^0.11.00.11.0up to date
 wol-rs^0.9.10.9.1up to date

Dev dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 hound^3.43.4.0up to date

Build dependencies

(2 total, 1 outdated)

CrateRequiredLatestStatus
 cc^1.01.0.73up to date
 flutter_rust_bridge_codegen=1.30.01.41.1out of date

Crate scrap

Dependencies

(6 total, all up-to-date)

CrateRequiredLatestStatus
 block^0.10.1.6up to date
 cfg-if^1.01.0.0up to date
 libc^0.20.2.131up to date
 num_cpus^1.131.13.1up to date
 lazy_static^1.41.4.0up to date
 winapi^0.30.3.9up to date

Build dependencies

(2 total, 1 outdated)

CrateRequiredLatestStatus
 target_build_utils^0.30.3.1up to date
 bindgen^0.590.60.1out of date

Crate hbb_common

Dependencies

(22 total, 3 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 protobuf^3.13.1.0up to date
 tokio^1.201.20.1up to date
 tokio-util^0.70.7.3up to date
 futures^0.30.3.23up to date
 bytes^1.21.2.1up to date
 log^0.40.4.17up to date
 env_logger^0.90.9.0up to date
 socket2^0.30.4.4out of date
 zstd^0.90.11.2+zstd.1.5.2out of date
 quinn^0.80.8.4up to date
 anyhow^1.01.0.61up to date
 futures-util^0.30.3.23up to date
 directories-next^2.02.0.0up to date
 rand^0.80.8.5up to date
 serde_derive^1.01.0.143up to date
 serde^1.01.0.143up to date
 serde_with^1.14.02.0.0out of date
 lazy_static^1.41.4.0up to date
 dirs-next^2.02.0.0up to date
 filetime^0.20.2.17up to date
 sodiumoxide^0.20.2.7up to date
 regex ⚠️^1.41.6.0maybe insecure

Dev dependencies

(2 total, all up-to-date)

CrateRequiredLatestStatus
 toml^0.50.5.9up to date
 serde_json^1.01.0.83up to date

Build dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 protobuf-codegen^3.13.1.0up to date

Crate simple_rc

Dependencies

(3 total, all up-to-date)

CrateRequiredLatestStatus
 serde_derive^1.01.0.143up to date
 serde^1.01.0.143up to date
 walkdir^22.3.2up to date

Crate enigo

Dependencies

(3 total, all up-to-date)

CrateRequiredLatestStatus
 serde^1.01.0.143up to date
 serde_derive^1.01.0.143up to date
 log^0.40.4.17up to date

Build dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 pkg-config^0.30.3.25up to date

Crate clipboard

Dependencies

(4 total, all up-to-date)

CrateRequiredLatestStatus
 thiserror^1.0.301.0.32up to date
 lazy_static^1.41.4.0up to date
 serde^1.01.0.143up to date
 serde_derive^1.01.0.143up to date

Build dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 cc^1.01.0.73up to date

Crate virtual_display

Dependencies

(4 total, all up-to-date)

CrateRequiredLatestStatus
 thiserror^1.0.301.0.32up to date
 lazy_static^1.41.4.0up to date
 serde^1.01.0.143up to date
 serde_derive^1.01.0.143up to date

Build dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 cc^1.01.0.73up to date

Security Vulnerabilities

regex: Regexes with large repetitions on empty sub-expressions take a very long time to parse

RUSTSEC-2022-0013

The Rust Security Response WG was notified that the regex crate did not properly limit the complexity of the regular expressions (regex) it parses. An attacker could use this security issue to perform a denial of service, by sending a specially crafted regex to a service accepting untrusted regexes. No known vulnerability is present when parsing untrusted input with trusted regexes.

This issue has been assigned CVE-2022-24713. The severity of this vulnerability is "high" when the regex crate is used to parse untrusted regexes. Other uses of the regex crate are not affected by this vulnerability.

Overview

The regex crate features built-in mitigations to prevent denial of service attacks caused by untrusted regexes, or untrusted input matched by trusted regexes. Those (tunable) mitigations already provide sane defaults to prevent attacks. This guarantee is documented and it's considered part of the crate's API.

Unfortunately a bug was discovered in the mitigations designed to prevent untrusted regexes to take an arbitrary amount of time during parsing, and it's possible to craft regexes that bypass such mitigations. This makes it possible to perform denial of service attacks by sending specially crafted regexes to services accepting user-controlled, untrusted regexes.

Affected versions

All versions of the regex crate before or equal to 1.5.4 are affected by this issue. The fix is include starting from regex 1.5.5.

Mitigations

We recommend everyone accepting user-controlled regexes to upgrade immediately to the latest version of the regex crate.

Unfortunately there is no fixed set of problematic regexes, as there are practically infinite regexes that could be crafted to exploit this vulnerability. Because of this, we do not recommend denying known problematic regexes.

Acknowledgements

We want to thank Addison Crump for responsibly disclosing this to us according to the Rust security policy, and for helping review the fix.

We also want to thank Andrew Gallant for developing the fix, and Pietro Albini for coordinating the disclosure and writing this advisory.