This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate reqwest

Dependencies

(43 total, 3 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 base64^0.210.21.0up to date
 bytes^1.01.3.0up to date
 futures-core^0.3.00.3.25up to date
 futures-util^0.3.00.3.25up to date
 http^0.20.2.8up to date
 mime_guess^2.02.0.4up to date
 serde^1.01.0.152up to date
 serde_json^1.01.0.91up to date
 serde_urlencoded^0.7.10.7.1up to date
 tower-service^0.30.3.2up to date
 url^2.22.3.1up to date
 async-compression^0.3.130.3.15up to date
 cookie^0.160.17.0out of date
 cookie_store^0.160.19.0out of date
 encoding_rs^0.80.8.31up to date
 h2^0.3.100.3.15up to date
 http-body^0.4.00.4.5up to date
 hyper^0.14.180.14.23up to date
 hyper-rustls^0.230.23.2up to date
 hyper-tls^0.50.5.0up to date
 ipnet^2.32.7.1up to date
 log^0.40.4.17up to date
 mime^0.3.160.3.16up to date
 native-tls^0.2.100.2.11up to date
 once_cell^11.17.0up to date
 percent-encoding^2.12.2.0up to date
 pin-project-lite^0.2.00.2.9up to date
 rustls^0.200.20.8up to date
 rustls-native-certs^0.60.6.2up to date
 rustls-pemfile^1.01.0.2up to date
 tokio ⚠️^1.01.24.2maybe insecure
 tokio-native-tls^0.3.00.3.0up to date
 tokio-rustls^0.230.23.4up to date
 tokio-socks^0.5.10.5.1up to date
 tokio-util^0.7.10.7.4up to date
 trust-dns-resolver^0.220.22.0up to date
 webpki-roots^0.220.22.6up to date
 js-sys^0.3.450.3.60up to date
 wasm-bindgen^0.2.680.2.83up to date
 wasm-bindgen-futures^0.4.180.4.33up to date
 wasm-streams^0.20.3.0out of date
 web-sys^0.3.250.3.60up to date
 winreg^0.100.10.1up to date

Dev dependencies

(9 total, 1 outdated, 2 possibly insecure)

CrateRequiredLatestStatus
 brotli^3.3.03.3.4up to date
 doc-comment^0.30.3.3up to date
 env_logger^0.80.10.0out of date
 hyper ⚠️^0.140.14.23maybe insecure
 libflate^1.01.2.0up to date
 serde^1.01.0.152up to date
 tokio ⚠️^1.01.24.2maybe insecure
 wasm-bindgen^0.2.680.2.83up to date
 wasm-bindgen-test^0.30.3.33up to date

Security Vulnerabilities

hyper: Lenient `hyper` header parsing of `Content-Length` could allow request smuggling

RUSTSEC-2021-0078

hyper's HTTP header parser accepted, according to RFC 7230, illegal contents inside Content-Length headers. Due to this, upstream HTTP proxies that ignore the header may still forward them along if it chooses to ignore the error.

To be vulnerable, hyper must be used as an HTTP/1 server and using an HTTP proxy upstream that ignores the header's contents but still forwards it. Due to all the factors that must line up, an attack exploiting this vulnerability is unlikely.

hyper: Integer overflow in `hyper`'s parsing of the `Transfer-Encoding` header leads to data loss

RUSTSEC-2021-0079

When decoding chunk sizes that are too large, hyper's code would encounter an integer overflow. Depending on the situation, this could lead to data loss from an incorrect total size, or in rarer cases, a request smuggling attack.

To be vulnerable, you must be using hyper for any HTTP/1 purpose, including as a client or server, and consumers must send requests or responses that specify a chunk size greater than 18 exabytes. For a possible request smuggling attack to be possible, any upstream proxies must accept a chunk size greater than 64 bits.

tokio: reject_remote_clients Configuration corruption

RUSTSEC-2023-0001

On Windows, configuring a named pipe server with pipe_mode will force ServerOptions::reject_remote_clients as false.

This drops any intended explicit configuration for the reject_remote_clients that may have been set as true previously.

The default setting of reject_remote_clients is normally true meaning the default is also overriden as false.

Workarounds

Ensure that pipe_mode is set first after initializing a ServerOptions. For example:

let mut opts = ServerOptions::new();
opts.pipe_mode(PipeMode::Message);
opts.reject_remote_clients(true);