This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate genkit

Dependencies

(29 total, 12 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 anyhow^1.01.0.86up to date
 async-trait^0.10.1.81up to date
 clap^44.5.9up to date
 dashmap^5.46.0.1out of date
 dyn-clone^1.01.0.17up to date
 fastwebsockets^0.40.8.0out of date
 futures^0.30.3.30up to date
 html5ever^0.260.27.0out of date
 hyper ⚠️^0.141.4.1out of date
 hyper-tls^0.50.6.0out of date
 markup5ever_rcdom^0.20.3.0out of date
 minijinja^12.0.3out of date
 notify-debouncer-mini^0.30.4.1out of date
 once_cell^11.19.0up to date
 opener^0.60.7.1out of date
 parking_lot^0.120.12.3up to date
 promptly^0.30.3.1up to date
 pulldown-cmark^0.90.11.0out of date
 rayon^1.61.10.0up to date
 serde^11.0.204up to date
 serde_json^11.0.120up to date
 syntect^55.2.0up to date
 time^0.30.3.36up to date
 tokio^1.261.38.1up to date
 toml^0.70.8.15out of date
 tower^0.40.4.13up to date
 tower-http^0.40.5.2out of date
 walkdir^22.5.0up to date
 words-count^0.10.1.6up to date

Dev dependencies

(3 total, all up-to-date)

CrateRequiredLatestStatus
 anyhow^1.01.0.86up to date
 parking_lot^0.120.12.3up to date
 test-case^33.3.1up to date

Security Vulnerabilities

hyper: Lenient `hyper` header parsing of `Content-Length` could allow request smuggling

RUSTSEC-2021-0078

hyper's HTTP header parser accepted, according to RFC 7230, illegal contents inside Content-Length headers. Due to this, upstream HTTP proxies that ignore the header may still forward them along if it chooses to ignore the error.

To be vulnerable, hyper must be used as an HTTP/1 server and using an HTTP proxy upstream that ignores the header's contents but still forwards it. Due to all the factors that must line up, an attack exploiting this vulnerability is unlikely.

hyper: Integer overflow in `hyper`'s parsing of the `Transfer-Encoding` header leads to data loss

RUSTSEC-2021-0079

When decoding chunk sizes that are too large, hyper's code would encounter an integer overflow. Depending on the situation, this could lead to data loss from an incorrect total size, or in rarer cases, a request smuggling attack.

To be vulnerable, you must be using hyper for any HTTP/1 purpose, including as a client or server, and consumers must send requests or responses that specify a chunk size greater than 18 exabytes. For a possible request smuggling attack to be possible, any upstream proxies must accept a chunk size greater than 64 bits.