This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate tauri

Dependencies

(60 total, 21 outdated, 2 possibly insecure)

CrateRequiredLatestStatus
 anyhow^1.01.0.86up to date
 base64^0.210.22.1out of date
 bytes^11.6.0up to date
 clap^34.5.4out of date
 cocoa^0.240.25.0out of date
 data-url^0.20.3.1out of date
 dirs-next^2.02.0.0up to date
 dunce^11.0.4up to date
 embed_plist^1.21.2.2up to date
 encoding_rs^0.8.310.8.34up to date
 flate2^1.01.0.30up to date
 futures-util^0.30.3.30up to date
 glib^0.150.19.7out of date
 glob^0.30.3.1up to date
 gtk^0.150.18.1out of date
 http^0.21.1.0out of date
 ico^0.2.00.3.0out of date
 ignore^0.40.4.22up to date
 indexmap^12.2.6out of date
 infer^0.90.15.0out of date
 minisign-verify^0.20.2.1up to date
 nix^0.26.00.29.0out of date
 notify-rust^4.54.11.0up to date
 objc^0.20.2.7up to date
 once_cell^11.19.0up to date
 open^3.25.1.3out of date
 os_info^33.8.2up to date
 os_pipe^1.01.1.5up to date
 percent-encoding^2.22.3.1up to date
 png^0.170.17.13up to date
 rand^0.80.8.5up to date
 raw-window-handle^0.50.6.2out of date
 regex ⚠️^11.10.4maybe insecure
 reqwest^0.110.12.4out of date
 rfd^0.100.14.1out of date
 semver^1.01.0.23up to date
 serde^1.01.0.203up to date
 serde_json^1.01.0.117up to date
 serde_repr^0.10.1.19up to date
 serialize-to-javascript=0.1.10.1.1up to date
 shared_child^1.01.0.0up to date
 state^0.50.6.0out of date
 sys-locale^0.2.30.3.1out of date
 tar^0.4.380.4.40up to date
 tauri-macros^1.4.41.4.4up to date
 tauri-runtime^0.14.30.14.3up to date
 tauri-runtime-wry^0.14.70.14.8up to date
 tauri-utils^1.5.41.5.4up to date
 tempfile^33.10.1up to date
 thiserror^1.01.0.61up to date
 time^0.30.3.36up to date
 tokio ⚠️^11.37.0maybe insecure
 tracing^0.10.1.40up to date
 url^2.32.5.0up to date
 uuid^11.8.0up to date
 webkit2gtk^0.18.22.0.1out of date
 webview2-com^0.19.10.30.0out of date
 win7-notifications^0.40.4.3up to date
 windows^0.39.00.56.0out of date
 zip^0.62.1.1out of date

Dev dependencies

(9 total, 2 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 cargo_toml^0.110.20.2out of date
 mockito^0.311.4.0out of date
 proptest^1.0.01.4.0up to date
 quickcheck^1.0.31.0.3up to date
 quickcheck_macros^1.0.01.0.0up to date
 serde^1.01.0.203up to date
 serde_json^1.01.0.117up to date
 tokio ⚠️^11.37.0maybe insecure
 tokio-test^0.4.20.4.4up to date

Security Vulnerabilities

regex: Regexes with large repetitions on empty sub-expressions take a very long time to parse

RUSTSEC-2022-0013

The Rust Security Response WG was notified that the regex crate did not properly limit the complexity of the regular expressions (regex) it parses. An attacker could use this security issue to perform a denial of service, by sending a specially crafted regex to a service accepting untrusted regexes. No known vulnerability is present when parsing untrusted input with trusted regexes.

This issue has been assigned CVE-2022-24713. The severity of this vulnerability is "high" when the regex crate is used to parse untrusted regexes. Other uses of the regex crate are not affected by this vulnerability.

Overview

The regex crate features built-in mitigations to prevent denial of service attacks caused by untrusted regexes, or untrusted input matched by trusted regexes. Those (tunable) mitigations already provide sane defaults to prevent attacks. This guarantee is documented and it's considered part of the crate's API.

Unfortunately a bug was discovered in the mitigations designed to prevent untrusted regexes to take an arbitrary amount of time during parsing, and it's possible to craft regexes that bypass such mitigations. This makes it possible to perform denial of service attacks by sending specially crafted regexes to services accepting user-controlled, untrusted regexes.

Affected versions

All versions of the regex crate before or equal to 1.5.4 are affected by this issue. The fix is include starting from regex 1.5.5.

Mitigations

We recommend everyone accepting user-controlled regexes to upgrade immediately to the latest version of the regex crate.

Unfortunately there is no fixed set of problematic regexes, as there are practically infinite regexes that could be crafted to exploit this vulnerability. Because of this, we do not recommend denying known problematic regexes.

Acknowledgements

We want to thank Addison Crump for responsibly disclosing this to us according to the Rust security policy, and for helping review the fix.

We also want to thank Andrew Gallant for developing the fix, and Pietro Albini for coordinating the disclosure and writing this advisory.

tokio: reject_remote_clients Configuration corruption

RUSTSEC-2023-0001

On Windows, configuring a named pipe server with pipe_mode will force ServerOptions::reject_remote_clients as false.

This drops any intended explicit configuration for the reject_remote_clients that may have been set as true previously.

The default setting of reject_remote_clients is normally true meaning the default is also overridden as false.

Workarounds

Ensure that pipe_mode is set first after initializing a ServerOptions. For example:

let mut opts = ServerOptions::new();
opts.pipe_mode(PipeMode::Message);
opts.reject_remote_clients(true);