This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate bat

Dependencies

(27 total, 1 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 atty^0.2.140.2.14up to date
 ansi_term^0.12.10.12.1up to date
 ansi_colours^1.01.0.4up to date
 bincode^1.01.3.3up to date
 console^0.15.00.15.0up to date
 flate2^1.01.0.22up to date
 once_cell^1.91.9.0up to date
 thiserror^1.01.0.30up to date
 wild^2.02.0.4up to date
 content_inspector^0.2.40.2.4up to date
 encoding^0.20.2.33up to date
 shell-words^1.0.01.0.0up to date
 unicode-width^0.1.90.1.9up to date
 globset^0.40.4.8up to date
 serde^1.01.0.133up to date
 serde_yaml ⚠️^0.80.8.23maybe insecure
 semver^1.01.0.4up to date
 path_abs^0.50.5.1up to date
 clircle^0.30.3.0up to date
 bugreport^0.40.4.1up to date
 dirs-next^2.0.02.0.0up to date
 grep-cli^0.1.60.1.6up to date
 regex^1.01.5.4up to date
 walkdir^2.02.3.2up to date
 git2^0.130.13.25up to date
 syntect^4.6.04.6.0up to date
 clap^2.343.0.10out of date

Dev dependencies

(5 total, all up-to-date)

CrateRequiredLatestStatus
 assert_cmd^2.0.22.0.4up to date
 serial_test^0.5.10.5.1up to date
 predicates^2.1.02.1.1up to date
 wait-timeout^0.2.00.2.0up to date
 tempfile^3.2.03.3.0up to date

Build dependencies

(1 total, 1 outdated)

CrateRequiredLatestStatus
 clap^2.343.0.10out of date

Security Vulnerabilities

serde_yaml: Uncontrolled recursion leads to abort in deserialization

RUSTSEC-2018-0005

Affected versions of this crate did not properly check for recursion while deserializing aliases.

This allows an attacker to make a YAML file with an alias referring to itself causing an abort.

The flaw was corrected by checking the recursion depth.