This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate ripgrep

Dependencies

(8 total, 1 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 bstr^0.2.120.2.17up to date
 lazy_static^1.1.01.4.0up to date
 log^0.4.50.4.17up to date
 num_cpus^1.8.01.13.1up to date
 regex ⚠️^1.3.51.5.6maybe insecure
 serde_json^1.0.231.0.82up to date
 termcolor^1.1.01.1.3up to date
 clap^2.33.03.2.8out of date

Dev dependencies

(3 total, all up-to-date)

CrateRequiredLatestStatus
 serde^1.0.771.0.138up to date
 serde_derive^1.0.771.0.138up to date
 walkdir^22.3.2up to date

Build dependencies

(2 total, 1 outdated)

CrateRequiredLatestStatus
 lazy_static^1.1.01.4.0up to date
 clap^2.33.03.2.8out of date

Crate grep

Dev dependencies

(2 total, all up-to-date)

CrateRequiredLatestStatus
 termcolor^1.0.41.1.3up to date
 walkdir^2.2.72.3.2up to date

Crate ignore

Dependencies

(8 total, 2 possibly insecure)

CrateRequiredLatestStatus
 crossbeam-utils^0.8.00.8.10up to date
 lazy_static^1.11.4.0up to date
 log^0.4.50.4.17up to date
 memchr^2.12.5.0up to date
 regex ⚠️^1.11.5.6maybe insecure
 same-file^1.0.41.0.6up to date
 thread_local ⚠️^11.1.4maybe insecure
 walkdir^2.2.72.3.2up to date

Dev dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 crossbeam-channel^0.5.00.5.5up to date

Crate globset

Dependencies

(6 total, 1 possibly insecure)

CrateRequiredLatestStatus
 aho-corasick^0.7.30.7.18up to date
 bstr^0.2.00.2.17up to date
 fnv^1.0.61.0.7up to date
 log^0.4.50.4.17up to date
 regex ⚠️^1.1.51.5.6maybe insecure
 serde^1.0.1041.0.138up to date

Dev dependencies

(3 total, all up-to-date)

CrateRequiredLatestStatus
 glob^0.3.00.3.0up to date
 lazy_static^11.4.0up to date
 serde_json^1.0.451.0.82up to date

Crate grep-cli

Dependencies

(7 total, 1 possibly insecure)

CrateRequiredLatestStatus
 atty^0.2.110.2.14up to date
 bstr^0.2.00.2.17up to date
 lazy_static^1.1.01.4.0up to date
 log^0.4.50.4.17up to date
 regex ⚠️^1.11.5.6maybe insecure
 same-file^1.0.41.0.6up to date
 termcolor^1.0.41.1.3up to date

Crate grep-matcher

Dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 memchr^2.12.5.0up to date

Dev dependencies

(1 total, 1 possibly insecure)

CrateRequiredLatestStatus
 regex ⚠️^1.11.5.6maybe insecure

Crate grep-pcre2

Dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 pcre2^0.2.30.2.3up to date

Crate grep-printer

Dependencies

(5 total, all up-to-date)

CrateRequiredLatestStatus
 base64^0.13.00.13.0up to date
 bstr^0.2.00.2.17up to date
 termcolor^1.0.41.1.3up to date
 serde^1.0.771.0.138up to date
 serde_json^1.0.271.0.82up to date

Crate grep-regex

Dependencies

(6 total, 2 possibly insecure)

CrateRequiredLatestStatus
 aho-corasick^0.7.30.7.18up to date
 bstr^0.2.100.2.17up to date
 log^0.4.50.4.17up to date
 regex ⚠️^1.11.5.6maybe insecure
 regex-syntax^0.6.50.6.26up to date
 thread_local ⚠️^1.1.21.1.4maybe insecure

Crate grep-searcher

Dependencies

(6 total, all up-to-date)

CrateRequiredLatestStatus
 bstr^0.2.00.2.17up to date
 bytecount^0.60.6.3up to date
 encoding_rs^0.8.140.8.31up to date
 encoding_rs_io^0.1.60.1.7up to date
 log^0.4.50.4.17up to date
 memmap2^0.5.30.5.4up to date

Dev dependencies

(1 total, 1 possibly insecure)

CrateRequiredLatestStatus
 regex ⚠️^1.11.5.6maybe insecure

Security Vulnerabilities

thread_local: Data race in `Iter` and `IterMut`

RUSTSEC-2022-0006

In the affected version of this crate, {Iter, IterMut}::next used a weaker memory ordering when loading values than what was required, exposing a potential data race when iterating over a ThreadLocal's values.

Crates using Iter::next, or IterMut::next are affected by this issue.

regex: Regexes with large repetitions on empty sub-expressions take a very long time to parse

RUSTSEC-2022-0013

The Rust Security Response WG was notified that the regex crate did not properly limit the complexity of the regular expressions (regex) it parses. An attacker could use this security issue to perform a denial of service, by sending a specially crafted regex to a service accepting untrusted regexes. No known vulnerability is present when parsing untrusted input with trusted regexes.

This issue has been assigned CVE-2022-24713. The severity of this vulnerability is "high" when the regex crate is used to parse untrusted regexes. Other uses of the regex crate are not affected by this vulnerability.

Overview

The regex crate features built-in mitigations to prevent denial of service attacks caused by untrusted regexes, or untrusted input matched by trusted regexes. Those (tunable) mitigations already provide sane defaults to prevent attacks. This guarantee is documented and it's considered part of the crate's API.

Unfortunately a bug was discovered in the mitigations designed to prevent untrusted regexes to take an arbitrary amount of time during parsing, and it's possible to craft regexes that bypass such mitigations. This makes it possible to perform denial of service attacks by sending specially crafted regexes to services accepting user-controlled, untrusted regexes.

Affected versions

All versions of the regex crate before or equal to 1.5.4 are affected by this issue. The fix is include starting from regex 1.5.5.

Mitigations

We recommend everyone accepting user-controlled regexes to upgrade immediately to the latest version of the regex crate.

Unfortunately there is no fixed set of problematic regexes, as there are practically infinite regexes that could be crafted to exploit this vulnerability. Because of this, we do not recommend denying known problematic regexes.

Acknowledgements

We want to thank Addison Crump for responsibly disclosing this to us according to the Rust security policy, and for helping review the fix.

We also want to thank Andrew Gallant for developing the fix, and Pietro Albini for coordinating the disclosure and writing this advisory.