This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate raft

Dependencies

(11 total, 1 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 bytes^11.1.0up to date
 fxhash^0.2.10.2.1up to date
 fail^0.40.5.0out of date
 getset^0.1.10.1.2up to date
 protobuf ⚠️^22.25.2maybe insecure
 thiserror^1.01.0.30up to date
 rand^0.80.8.4up to date
 slog^2.22.7.0up to date
 slog-envlogger^2.1.02.2.0up to date
 slog-stdlog^44.1.0up to date
 slog-term^2.4.02.8.0up to date

Dev dependencies

(8 total, all up-to-date)

CrateRequiredLatestStatus
 criterion^0.30.3.5up to date
 regex^11.5.4up to date
 slog-async^2.3.02.7.0up to date
 slog-envlogger^2.1.02.2.0up to date
 slog-stdlog^44.1.0up to date
 slog-term^2.4.02.8.0up to date
 anyhow^1.0.401.0.53up to date
 itertools^0.10.00.10.3up to date

Crate raft-proto

Dependencies

(4 total, 1 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 bytes^11.1.0up to date
 lazy_static^11.4.0up to date
 prost^0.70.9.0out of date
 protobuf ⚠️^22.25.2maybe insecure

Build dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 protobuf-build^0.120.12.3up to date

Crate datadriven

Dependencies

(7 total, all up-to-date)

CrateRequiredLatestStatus
 anyhow^1.0.401.0.53up to date
 regex^11.5.4up to date
 lazy_static^1.4.01.4.0up to date
 slog^2.5.22.7.0up to date
 slog-term^2.6.02.8.0up to date
 slog-async^2.5.02.7.0up to date
 similar-asserts^1.1.01.2.0up to date

Crate harness

Dependencies

(2 total, all up-to-date)

CrateRequiredLatestStatus
 rand^0.80.8.4up to date
 slog^2.22.7.0up to date

Dev dependencies

(5 total, 1 possibly insecure)

CrateRequiredLatestStatus
 criterion^0.30.3.5up to date
 fxhash^0.2.10.2.1up to date
 lazy_static^11.4.0up to date
 protobuf ⚠️^22.25.2maybe insecure
 regex^11.5.4up to date

Security Vulnerabilities

protobuf: Out of Memory in stream::read_raw_bytes_into()

RUSTSEC-2019-0003

Affected versions of this crate called Vec::reserve() on user-supplied input.

This allows an attacker to cause an Out of Memory condition while calling the vulnerable method on untrusted data.