This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate cargo-generate

Dependencies

(28 total, 2 possibly insecure)

CrateRequiredLatestStatus
 clap^3.23.2.8up to date
 git2^0.140.14.4up to date
 console^0.150.15.0up to date
 dialoguer^0.100.10.1up to date
 dirs^4.04.0.0up to date
 indicatif^0.160.16.2up to date
 tempfile^3.33.3.0up to date
 regex ⚠️^1.51.5.6maybe insecure
 heck^0.40.4.0up to date
 walkdir^2.32.3.2up to date
 remove_dir_all^0.70.7.0up to date
 ignore^0.40.4.18up to date
 anyhow^1.01.0.58up to date
 toml^0.50.5.9up to date
 thiserror^1.01.0.31up to date
 home^0.50.5.3up to date
 sanitize-filename^0.40.4.0up to date
 rhai^1.61.8.0up to date
 path-absolutize^3.03.0.13up to date
 git-config^0.5.00.5.0up to date
 paste^1.01.0.7up to date
 liquid^0.260.26.0up to date
 liquid-core^0.260.26.0up to date
 liquid-lib^0.260.26.0up to date
 liquid-derive^0.260.26.0up to date
 openssl ⚠️^0.100.10.40maybe insecure
 semver^1.01.0.12up to date
 serde^1.01.0.138up to date

Dev dependencies

(5 total, all up-to-date)

CrateRequiredLatestStatus
 predicates^2.12.1.1up to date
 assert_cmd^2.02.0.4up to date
 indoc^1.01.0.6up to date
 url^2.22.2.2up to date
 cargo-husky^11.5.0up to date

Security Vulnerabilities

openssl: Use after free in CMS Signing

RUSTSEC-2018-0010

Affected versions of the OpenSSL crate used structures after they'd been freed.

regex: Regexes with large repetitions on empty sub-expressions take a very long time to parse

RUSTSEC-2022-0013

The Rust Security Response WG was notified that the regex crate did not properly limit the complexity of the regular expressions (regex) it parses. An attacker could use this security issue to perform a denial of service, by sending a specially crafted regex to a service accepting untrusted regexes. No known vulnerability is present when parsing untrusted input with trusted regexes.

This issue has been assigned CVE-2022-24713. The severity of this vulnerability is "high" when the regex crate is used to parse untrusted regexes. Other uses of the regex crate are not affected by this vulnerability.

Overview

The regex crate features built-in mitigations to prevent denial of service attacks caused by untrusted regexes, or untrusted input matched by trusted regexes. Those (tunable) mitigations already provide sane defaults to prevent attacks. This guarantee is documented and it's considered part of the crate's API.

Unfortunately a bug was discovered in the mitigations designed to prevent untrusted regexes to take an arbitrary amount of time during parsing, and it's possible to craft regexes that bypass such mitigations. This makes it possible to perform denial of service attacks by sending specially crafted regexes to services accepting user-controlled, untrusted regexes.

Affected versions

All versions of the regex crate before or equal to 1.5.4 are affected by this issue. The fix is include starting from regex 1.5.5.

Mitigations

We recommend everyone accepting user-controlled regexes to upgrade immediately to the latest version of the regex crate.

Unfortunately there is no fixed set of problematic regexes, as there are practically infinite regexes that could be crafted to exploit this vulnerability. Because of this, we do not recommend denying known problematic regexes.

Acknowledgements

We want to thank Addison Crump for responsibly disclosing this to us according to the Rust security policy, and for helping review the fix.

We also want to thank Andrew Gallant for developing the fix, and Pietro Albini for coordinating the disclosure and writing this advisory.