This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate alacritty

Dependencies

(16 total, 2 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 clap^3.0.03.2.22up to date
 log^0.40.4.17up to date
 fnv^11.0.7up to date
 serde^11.0.145up to date
 serde_yaml ⚠️^0.80.9.13out of date
 serde_json^11.0.85up to date
 glutin^0.29.10.29.1up to date
 notify^45.0.0out of date
 parking_lot^0.12.00.12.1up to date
 crossfont^0.5.00.5.0up to date
 copypasta^0.8.10.8.1up to date
 libc^0.20.2.133up to date
 unicode-width^0.10.1.10up to date
 bitflags^11.3.2up to date
 dirs^4.0.04.0.0up to date
 once_cell^1.121.15.0up to date

Dev dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 clap_complete^3.0.03.2.5up to date

Build dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 gl_generator^0.14.00.14.0up to date

Crate alacritty_terminal

Dependencies

(13 total, 4 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 libc^0.20.2.133up to date
 bitflags^11.3.2up to date
 parking_lot^0.12.00.12.1up to date
 serde^11.0.145up to date
 serde_yaml ⚠️^0.80.9.13out of date
 vte^0.10.00.11.0out of date
 mio^0.6.200.8.4out of date
 mio-extras^22.0.6up to date
 log^0.40.4.17up to date
 unicode-width^0.10.1.10up to date
 base64^0.13.00.13.0up to date
 regex-automata^0.1.90.2.0out of date
 dirs^4.0.04.0.0up to date

Dev dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 serde_json^1.0.01.0.85up to date

Crate alacritty_config

Dependencies

(3 total, 1 outdated)

CrateRequiredLatestStatus
 log^0.4.170.4.17up to date
 serde_yaml^0.8.240.9.13out of date
 serde^1.0.1371.0.145up to date

Crate alacritty_config_derive

Dependencies

(3 total, all up-to-date)

CrateRequiredLatestStatus
 syn^1.0.531.0.101up to date
 proc-macro2^1.0.241.0.44up to date
 quote^1.0.71.0.21up to date

Dev dependencies

(3 total, 1 outdated)

CrateRequiredLatestStatus
 serde^1.0.1171.0.145up to date
 serde_yaml^0.8.140.9.13out of date
 log^0.4.110.4.17up to date

Security Vulnerabilities

serde_yaml: Uncontrolled recursion leads to abort in deserialization

RUSTSEC-2018-0005

Affected versions of this crate did not properly check for recursion while deserializing aliases.

This allows an attacker to make a YAML file with an alias referring to itself causing an abort.

The flaw was corrected by checking the recursion depth.