This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate tiny_http

Dependencies

(9 total, 1 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 ascii^1.01.1.0up to date
 chunked_transfer^11.4.0up to date
 log^0.40.4.17up to date
 openssl ⚠️^0.100.10.42maybe insecure
 rustls^0.200.20.6up to date
 rustls-pemfile^0.2.11.0.1out of date
 time^0.30.3.14up to date
 url^22.3.1up to date
 zeroize^1.5.21.5.7up to date

Dev dependencies

(3 total, 2 outdated, 1 insecure)

CrateRequiredLatestStatus
 fdlimit^0.10.2.1out of date
 rustc-serialize ⚠️^0.30.3.24insecure
 sha1^0.6.00.10.5out of date

Security Vulnerabilities

openssl: Use after free in CMS Signing

RUSTSEC-2018-0010

Affected versions of the OpenSSL crate used structures after they'd been freed.

rustc-serialize: Stack overflow in rustc_serialize when parsing deeply nested JSON

RUSTSEC-2022-0004

When parsing JSON using json::Json::from_str, there is no limit to the depth of the stack, therefore deeply nested objects can cause a stack overflow, which aborts the process.

Example code that triggers the vulnerability is

fn main() {
    let _ = rustc_serialize::json::Json::from_str(&"[0,[".repeat(10000));
}

serde is recommended as a replacement to rustc_serialize.