This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate flutter_rust_bridge_codegen

Dependencies

(22 total, 7 outdated, 2 possibly insecure)

CrateRequiredLatestStatus
 anyhow^1.0.641.0.68up to date
 cargo_metadata^0.14.10.15.2out of date
 cbindgen^0.240.24.3up to date
 clap^3.2.144.1.4out of date
 convert_case^0.5.00.6.0out of date
 delegate^0.8.00.9.0out of date
 enum_dispatch^0.3.80.3.11up to date
 env_logger^0.9.00.10.0out of date
 extend^1.1.21.1.2up to date
 itertools^0.10.30.10.5up to date
 lazy_static^1.4.01.4.0up to date
 log^0.40.4.17up to date
 pathdiff^0.2.10.2.1up to date
 quote^1.01.0.23up to date
 regex ⚠️^1.5.41.7.1maybe insecure
 serde^1.01.0.152up to date
 serde_yaml ⚠️^0.80.9.17out of date
 syn^1.0.771.0.107up to date
 tempfile^3.2.03.3.0up to date
 thiserror^11.0.38up to date
 toml^0.5.80.7.0out of date
 topological-sort^0.2.20.2.2up to date

Dev dependencies

(1 total, all up-to-date)

CrateRequiredLatestStatus
 semver^1.0.121.0.16up to date

Security Vulnerabilities

serde_yaml: Uncontrolled recursion leads to abort in deserialization

RUSTSEC-2018-0005

Affected versions of this crate did not properly check for recursion while deserializing aliases.

This allows an attacker to make a YAML file with an alias referring to itself causing an abort.

The flaw was corrected by checking the recursion depth.

regex: Regexes with large repetitions on empty sub-expressions take a very long time to parse

RUSTSEC-2022-0013

The Rust Security Response WG was notified that the regex crate did not properly limit the complexity of the regular expressions (regex) it parses. An attacker could use this security issue to perform a denial of service, by sending a specially crafted regex to a service accepting untrusted regexes. No known vulnerability is present when parsing untrusted input with trusted regexes.

This issue has been assigned CVE-2022-24713. The severity of this vulnerability is "high" when the regex crate is used to parse untrusted regexes. Other uses of the regex crate are not affected by this vulnerability.

Overview

The regex crate features built-in mitigations to prevent denial of service attacks caused by untrusted regexes, or untrusted input matched by trusted regexes. Those (tunable) mitigations already provide sane defaults to prevent attacks. This guarantee is documented and it's considered part of the crate's API.

Unfortunately a bug was discovered in the mitigations designed to prevent untrusted regexes to take an arbitrary amount of time during parsing, and it's possible to craft regexes that bypass such mitigations. This makes it possible to perform denial of service attacks by sending specially crafted regexes to services accepting user-controlled, untrusted regexes.

Affected versions

All versions of the regex crate before or equal to 1.5.4 are affected by this issue. The fix is include starting from regex 1.5.5.

Mitigations

We recommend everyone accepting user-controlled regexes to upgrade immediately to the latest version of the regex crate.

Unfortunately there is no fixed set of problematic regexes, as there are practically infinite regexes that could be crafted to exploit this vulnerability. Because of this, we do not recommend denying known problematic regexes.

Acknowledgements

We want to thank Addison Crump for responsibly disclosing this to us according to the Rust security policy, and for helping review the fix.

We also want to thank Andrew Gallant for developing the fix, and Pietro Albini for coordinating the disclosure and writing this advisory.