This project contains:

  • 4 outdated main dependencies
  • 1 outdated development dependency

Crate argmin

Dependencies

(17 total, all up-to-date)

CrateRequiredLatestStatus
 anyhow^1.01.0.57up to date
 instant^0.10.1.12up to date
 paste^11.0.7up to date
 num-traits^0.20.2.15up to date
 rand^0.8.30.8.5up to date
 thiserror^1.01.0.31up to date
 bincode^1.3.31.3.3up to date
 ctrlc^3.1.23.2.2up to date
 getrandom^0.20.2.6up to date
 gnuplot^0.0.370.0.37up to date
 rayon^1.5.21.5.2up to date
 serde^1.01.0.137up to date
 serde_json^1.01.0.81up to date
 slog^2.4.12.7.0up to date
 slog-term^2.8.12.9.0up to date
 slog-async^2.7.02.7.0up to date
 slog-json^2.5.02.6.1up to date

Dev dependencies

(8 total, all up-to-date)

CrateRequiredLatestStatus
 approx^0.5.00.5.1up to date
 finitediff^0.1.40.1.4up to date
 argmin_testfunctions^0.1.10.1.1up to date
 rand_xoshiro^0.6.00.6.0up to date
 nalgebra^0.310.31.0up to date
 ndarray^0.150.15.4up to date
 ndarray-linalg^0.140.14.1up to date
 serde^1.01.0.137up to date

Crate argmin-math

Dependencies

(10 total, 4 outdated)

CrateRequiredLatestStatus
 nalgebra^0.290.31.0out of date
 ndarray^0.130.15.4out of date
 ndarray-linalg^0.120.14.1out of date
 num-complex^0.20.4.1out of date
 num-traits^0.20.2.15up to date
 num-integer^0.10.1.45up to date
 rand^0.8.30.8.5up to date
 anyhow^1.01.0.57up to date
 thiserror^1.01.0.31up to date
 cfg-if^11.0.0up to date

Dev dependencies

(2 total, 1 outdated)

CrateRequiredLatestStatus
 ndarray-linalg^0.120.14.1out of date
 paste^11.0.7up to date