This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate tokio-util

Dependencies

(10 total, 1 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 bytes^1.0.01.6.0up to date
 futures-core^0.3.00.3.30up to date
 futures-io^0.3.00.3.30up to date
 futures-sink^0.3.00.3.30up to date
 futures-util^0.3.00.3.30up to date
 hashbrown^0.12.00.14.3out of date
 pin-project-lite^0.2.00.2.14up to date
 slab^0.4.40.4.9up to date
 tokio ⚠️^1.22.01.37.0maybe insecure
 tracing^0.1.250.1.40up to date

Dev dependencies

(7 total, 1 possibly insecure)

CrateRequiredLatestStatus
 async-stream^0.3.00.3.5up to date
 futures^0.3.00.3.30up to date
 futures-test^0.3.50.3.30up to date
 parking_lot^0.12.00.12.1up to date
 tokio ⚠️^1.0.01.37.0maybe insecure
 tokio-stream^0.10.1.15up to date
 tokio-test^0.4.00.4.4up to date

Security Vulnerabilities

tokio: reject_remote_clients Configuration corruption

RUSTSEC-2023-0001

On Windows, configuring a named pipe server with pipe_mode will force ServerOptions::reject_remote_clients as false.

This drops any intended explicit configuration for the reject_remote_clients that may have been set as true previously.

The default setting of reject_remote_clients is normally true meaning the default is also overridden as false.

Workarounds

Ensure that pipe_mode is set first after initializing a ServerOptions. For example:

let mut opts = ServerOptions::new();
opts.pipe_mode(PipeMode::Message);
opts.reject_remote_clients(true);