This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate rusqlite

Dependencies

(13 total, 4 outdated, 2 possibly insecure)

CrateRequiredLatestStatus
 bitflags^1.22.5.0out of date
 chrono ⚠️^0.40.4.37maybe insecure
 csv^1.11.3.0up to date
 fallible-iterator^0.20.3.0out of date
 fallible-streaming-iterator^0.10.1.9up to date
 hashlink^0.80.9.0out of date
 lazy_static^1.41.4.0up to date
 libsqlite3-sys ⚠️^0.25.00.28.0out of date
 serde_json^1.01.0.115up to date
 smallvec^1.6.11.13.2up to date
 time^0.3.00.3.36up to date
 url^2.12.5.0up to date
 uuid^1.01.8.0up to date

Dev dependencies

(7 total, all up-to-date)

CrateRequiredLatestStatus
 bencher^0.10.1.5up to date
 doc-comment^0.30.3.3up to date
 lazy_static^1.41.4.0up to date
 regex^1.5.51.10.4up to date
 tempfile^3.1.03.10.1up to date
 unicase^2.6.02.7.0up to date
 uuid^1.01.8.0up to date

Security Vulnerabilities

chrono: Potential segfault in `localtime_r` invocations

RUSTSEC-2020-0159

Impact

Unix-like operating systems may segfault due to dereferencing a dangling pointer in specific circumstances. This requires an environment variable to be set in a different thread than the affected functions. This may occur without the user's knowledge, notably in a third-party library.

Workarounds

No workarounds are known.

References

libsqlite3-sys: `libsqlite3-sys` via C SQLite CVE-2022-35737

RUSTSEC-2022-0090

It was sometimes possible for SQLite versions >= 1.0.12, < 3.39.2 to allow an array-bounds overflow when large string were input into SQLite's printf function.

As libsqlite3-sys bundles SQLite, it is susceptible to the vulnerability. libsqlite3-sys was updated to bundle the patched version of SQLite here.