This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate quickcheck

Dependencies

(4 total, 3 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 env_logger^0.50.9.0out of date
 log^0.40.4.14up to date
 rand^0.50.8.4out of date
 rand_core ⚠️^0.2.10.6.3out of date

Security Vulnerabilities

rand_core: Unaligned memory access

RUSTSEC-2019-0035

Affected versions of this crate violated alignment when casting byte slices to integer slices, resulting in undefined behavior.

The flaw was corrected by Ralf Jung and Diggory Hardy.