This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate pcre2

Dependencies

(4 total, 1 possibly insecure)

CrateRequiredLatestStatus
 libc^0.2.460.2.125up to date
 log^0.4.50.4.17up to date
 pcre2-sys^0.2.00.2.5up to date
 thread_local ⚠️^11.1.4maybe insecure

Security Vulnerabilities

thread_local: Data race in `Iter` and `IterMut`

RUSTSEC-2022-0006

In the affected version of this crate, {Iter, IterMut}::next used a weaker memory ordering when loading values than what was required, exposing a potential data race when iterating over a ThreadLocal's values.

Crates using Iter::next, or IterMut::next are affected by this issue.