This project might be open to known security vulnerabilities, which can be prevented by tightening the version range of affected dependencies. Find detailed information at the bottom.

Crate crypto-tests

Dependencies

(4 total, 3 outdated, 1 possibly insecure)

CrateRequiredLatestStatus
 generic-array ⚠️^0.80.14.4out of date
 digest^0.60.9.0out of date
 block-cipher-trait^0.4N/Aup to date
 crypto-mac^0.40.11.1out of date

Security Vulnerabilities

generic-array: arr! macro erases lifetimes

RUSTSEC-2020-0146

Affected versions of this crate allowed unsoundly extending lifetimes using arr! macro. This may result in a variety of memory corruption scenarios, most likely use-after-free.